Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » forms not running
forms not running [message #167953] Tue, 18 April 2006 01:58 Go to next message
Messages: 14
Registered: October 2005
Location: Pakistan
Junior Member
i have just shifted from oracle application server 10g(9.0.4) to realease 2 (10.1.2). i have moved all my form application to the new server but now when i invoke the form appication and first applet window is showing me error message java.lang.ClassNotFoundException:oracle.forms.engine.Main

What could be the problem?

One thing more that i dont have lates frmwebutil.jar and jacob.jar file. Do i need to install those files also? as these exist on the old server with the name webutil.jar.
what is the link todownload frmwebutil.jar?
any other clue?
Re: forms not running [message #168056 is a reply to message #167953] Tue, 18 April 2006 09:58 Go to previous messageGo to next message
Messages: 48
Registered: March 2006

I had your problem and solved it without installing webutil (see my post on this forum).

In Control Panel -> JInitiator administration console , the option "Use browser settings" has to be unchecked.

Re: forms not running [message #168160 is a reply to message #168056] Wed, 19 April 2006 02:31 Go to previous messageGo to next message
Messages: 14
Registered: October 2005
Location: Pakistan
Junior Member
thanks for your reply. see what i did

1) When i invoke the application from the older version of application server (9.0.4), it works fine and without any problem and without changing any setting for JINITIATOR. If JINITIATOR is not installed, it automaticlly installs jinitiator

2) When i prepared the new application server (10.1.2) and deployed my application on the new server, It started giving me this problem.

3) Now i uninstalled the jinitiator and now called the application from new server but applet window is open but doesnt show anything and it didnt install jinitiato either. Now i again called application from old server and it first installed jinitiator and then application ran successfully.

4) Now i again called application from new server but same problem as i mentioned in point 3 (remember that "use browser setting" is unchecked.

My question is that how jinitator is installed autmatically? How would i install it manually if Applet window is not running if application is called from 10.1.2 server.

Now from another machine, i tried to run the application from the new server and i am succesfull Razz . It means that it was only client side setting.

Any ways now another problem that applicatin is returing a message "FRM-40011: Form was created bu an old version of form buiilder"
How to solve this problem?
The version of forms builder used to develop forms application is ""

  • Attachment: Error.JPG
    (Size: 61.44KB, Downloaded 1450 times)

[Updated on: Wed, 19 April 2006 02:38]

Report message to a moderator

Re: forms not running [message #230624 is a reply to message #168160] Thu, 12 April 2007 06:28 Go to previous messageGo to next message
Messages: 1
Registered: April 2007
Location: Lahore
Junior Member


I have the same problem but i solved it. You have to read a file in %ora-dev%\forms\server\formsweb.cfg and update it according to your requirment like

ip of your server or name in host
port# which server use to run
and many more

if you need more help then e-mail me on mazhar_83@hotmail.com with subject "ORACLE 10g FORM HELP".

I have documents which help you to be expert in 10g

Re: forms not running [message #231684 is a reply to message #167953] Wed, 18 April 2007 02:06 Go to previous message
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

Mazhar is absolutely right. I installed patches to my iAS upto I just take backup copies of conf files to save myself. And after installation of Patches and i replaced the new conf files with old one. my server start giving problems to new users. So i replaced with new ones that was copied by patches and now my server is happy and running nicely.

Zeeshan Ali Awan
Previous Topic: Performance problem with 10G Application Server via internet
Next Topic: J2EE Sample Applications
Goto Forum:

Current Time: Thu May 30 04:09:43 CDT 2024